首页 > 股票投资 > 股票技术指标公式 > 正文

深水捕庄器指标使用及源码的讲解

来源:【赢家江恩】责任编辑:yjcf360添加时间:2019-01-02 10:03:12

  深水捕庄器指标是一种可捕捉庄股的指标,这个指标可以帮助我们很好的进行股票买卖。那究竟深水捕庄器指标怎么样使用?相对应的公式源码是什么?感兴趣的朋友,今天就可以跟随赢家学院的主编老师来详细的了解。

  一、使用

  深水捕庄器指标如何使用?首先说明一点,这个指标不含有未来函数,所以大家可以放心的使用。这个指标的呈现方式如下图所示,当这个指标出现红柱信号提示时,那么就可以列为是买入信号。

  当出现如上面的绿柱的信号时,此时就是我们的止损或者清仓时机。当然在这之外的灰柱,那么就是本波段的过程之中,蓝色小框内数字是已经达标已收益5%点的持续天数。

  二、优点

  深水捕庄器指标属于高级技术指标,即既有买点信号提示,同时又有卖点信号提示,指标除了精准外,最大的优点是只要指标出现买点信号提示,那么一段时间后必有卖点信号提示,即有买有卖。同时这个指标还配有相应的选股指标,它就是我们的预警指标,如果选股的话,其选股时机同样还是我们的收盘前半小时。

  三、源码

  1、“深水捕庄器”指标源码(副图)

  OK:=REF(CLOSE,1);

  鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;

  RSI4:=SMA(鱼,7,1);

  HH:=BARSLAST(鱼<><>

  白绿线:=SMA(鱼,7,1);

  深水鱼:=CROSS(鱼,RSI4) AND 白绿线>15 AND HH;

  BU:=深水鱼;

  BB2:=IF(C>REF((6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1),1),1,IF(C

  DD2:=BARSLAST(NOT(BB2=0));

  B:=IF(BB2=0,REF(BB2,DD2),BB2);

  触发:BU,NODRAW,COLORRED;

  止损:C0)) AND COUNT(C0)),BARSLAST(BU>0))=1 AND IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)>0,NODRAW, COLORGREEN;

  止盈:(H/REF(C,BARSLAST(BU>0))>=1.05 OR C/REF(C,BARSLAST(BU>0))>=1.05) AND COUNT(止损,BARSLAST(BU>0))=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)),BARSLAST(BU>0))=0,NODRAW, COLORBLUE;

  区间:COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)), BARSLAST(BU>0)+1)=0,NODRAW,COLOR696960;

  结束:(COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1)), BARSLAST(BU>0)+1)=1 AND CROSS(0,IF(MA(CLOSE,1)>IF(B=-1,MA(HIGH,6),MA(LOW,6)) ,1,-1))) OR 止损,NODRAW, COLORGREEN;

  STICKLINE(触发>0,0,1,4,0),COLORRED;

  STICKLINE(止盈>0 ,0.3,0.6,4,0) COLORBLUE;

  STICKLINE(结束>0,0,1,4,0) COLORGREEN;

  TS:=BARSLASTCOUNT(止盈>0);

  DRAWTEXT(止盈>0,0.5,VAR2STR(TS,0));

  2、“深水捕庄器”指标源码(选股)

  OK:=REF(CLOSE,1);

  鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;

  RSI4:=SMA(鱼,7,1);

  HH:=BARSLAST(鱼<><>

  白绿线:=SMA(鱼,7,1);

  深水鱼:=CROSS(鱼,RSI4) AND 白绿线>15 AND HH;

  BU:=深水鱼;

  BB2:=IF(C>REF((6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1),1),1,IF(C

  DD2:=BARSLAST(NOT(BB2=0));

  B:=IF(BB2=0,REF(BB2,DD2),BB2);

  触发:=BU,NODRAW;

  XG:触发>0;

  深水捕庄器指标使用及源码的讲解就到这里,相信大家对此已经掌握了,如若您想要学习更多指标的运用,可以关注本栏目的更新,最后预祝大家元旦快乐。

郑州亨瑞软件开发有限公司
版权所有

服务中心:郑州市金水区农业路经三路
邮编:450002 网址:www.yingjia360.com

销售热线:0371-65350318/65350319
技术支持:13333833889

注册下载;