首页 > 江恩理论 > 江恩八线 > 正文

如何在炒股软件上设置江恩八线指标

来源:【赢家江恩】责任编辑:chengang添加时间:2015-01-22 16:58:10
  江恩八线指标曾因民间股神殷保华而名噪一时,该指标是基于江恩理论思想精华总结出来的。受到很多朋友的推崇,对追求技术分析的朋友有一定的实战意义。不过还有很多朋友不知道如何在软件里设定该指标。因此,笔者借此给大家介绍下,如何在股票软件上设定该指标(本文以通达信软件为例)。
  
  江恩八线指标的源代码如下(主图):
  
  大盘:=EMA(INDEXC,500)/EMA(C,500);  
  大盘线:=INDEXC/大盘,LINETHICK1,COLORBLUE;  
  工作线:EMA(C,14),COLOR00FFFF,LINETHICK1;  
  一号线:EMA(CLOSE,144),POINTDOT,LINETHICK2,COLOR0000FF;  
  二号线:EMA(C,25),COLORWHITE,LINETHICK2;  
  三号线:EMA(C,318),COLOR0000FF,LINETHICK2;  
  四黑马线:EMA(C,453),CIRCLEDOT,LINETHICK1,COLOR428899;  
  五号线:EMA(C,550),COLORFFCC66;  
  六号线:EMA(C,610),LINETHICK2,COLORYELLOW;  
  七号线:EMA(C,730),COLORBLUE;  
  八号线:EMA(C,99),POINTDOT,LINETHICK2,COLORWHITE;  
  DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),COLORWHITE;  
  DEA:=EMA(DIFF,9),COLORF00FF0 ;  
  MACD:=0.90*(DIFF-DEA), COLORSTICK;  
  TJ:=(DIFF>=DEA);  
  TJ1:=(DIFF>=0);  
  {STICKLINE(TJ,H,L,0,0),COLORYELLOW;}  
  STICKLINE(TJ,O,C,3,1),COLORYELLOW;  
  STICKLINE(TJ1 AND TJ,H,L,0,1),COLORF00FF0;  
  STICKLINE(TJ1 AND TJ,O,C,3,1),COLORF00FF0;  
  STICKLINE(DIFF<DEA,H,L,0,0),COLORF0F000;  
  STICKLINE(DIFF<DEA,O,C,3,1),COLORF0F000;  
  VAR1:=(CLOSE*2+HIGH+LOW)/4;  
  SK:= EMA(VAR1,13)-EMA(VAR1,73);  
  SD:= EMA(SK,2);  
  {DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),COLORFF66FF;}  
  STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0,0),COLORRED;  
  STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,3,0),LINETHICK3,COLORRED;  
  SS:=CROSS(二号线,八号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98  
  OR CROSS(二号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98  
  OR CROSS(二号线,一号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98{AND CROSS(二号线,三号线)};  
  {DRAWICON(SS,L-0.04,1);}  
  DD:=CROSS(八号线,一号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98  
  OR CROSS(八号线,四黑马线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98  
  OR CROSS(八号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98  
  OR CROSS(八号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98 AND CROSS(二号线,四黑马线);
  
  打开通达信软件,依次点击【功能】—【公式系统】—【公式管理器】—【新建】—【指标编辑器】,然后填入上方的代码,并选择相应的设定如下图:
  
江恩八线设定
 
  点击【确定】保存即可。然后回到软件主界面,键盘敲击设定名称的缩写。我上面设定的名称为江恩八线,因此可以敲击JEBX,就可以调出该指标,如下图所示:
  
江恩八线展示
 
  江恩八线指标的操作精髓是:线上阴线买,买错了也不要放手,线下阳线卖,卖错了也要卖。
  
  作为一个技术指标,投资者在使用的时候一定要灵活运用,关于该指标的讲解本站也有很多探讨。大家要根据实际情况分析自己的股票,切记不要痴迷于指标,要学会灵活使用。另外,该指标搜集与网络,只做技术探讨,不构成任何投资建议。想学习该指标及江恩理论的朋友,可以留意本站的江恩理论板块,学习过程中,如有不解或困难可以联系赢家在线客服,祝大家投资顺利!
郑州亨瑞软件开发有限公司
版权所有

服务中心:郑州市金水区农业路经三路
邮编:450002 网址:www.yingjia360.com

销售热线:0371-65350319
技术支持:13333833889

注册下载;