首页 > 股票投资 > 股票技术指标公式 > 正文

牵牛波段指标公式源码的相关分享

来源:【赢家江恩】责任编辑:zhangxueli添加时间:2017-09-23 09:51:45
  股票投资市场中总是会遇到很多的技术指标,在飞狐软件中就有一个牵牛波段指标,在使用这个牵牛波段指标的时候相对来说是比较简单的。那究竟该指标公式源码是怎么样的?如果您对于公式源码还没有掌握的话,那今天就可以跟随小编来详细的了解。

  牵牛波段指标公式是怎么样的?如下图所示,它是有很四条线所组成的,最为中要就是黄线、紫色线,白线和蓝线。从下图可以看出每一次黄线金叉紫色线的时候,所对应的股价都是出现底部的区域,显然是一个买点的提示,所以该指标的金叉与死叉与其它指标的用法是相同的。

牵牛波段指标公式源码.jpg

  【牵牛波段指标公式源码】

  {牵牛波段}

  input:N(3,1,10),N2(6,1,10),N3(23,0,50),N4(75,50,100);

  DRAWGBK((CLOSE > 0),COLORRGB(0,130,100),COLORRGB(0,0,30),1);

  VAR1:=1;

  VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);

  VAR3:=(((CLOSE - LLV(LOW,18)) / (HHV(HIGH,18) - LLV(LOW,18))) * 100);

  VAR4:=SMA(VAR3,9,1);

  VAR5:=SMA(VAR4,3,1);

  黄线在上持股:((3 * VAR4) - (2 * VAR5)),LINETHICK2,colorFFFF;

  VAR6:=(黄线在上持股 > (1 * REF(黄线在上持股,1)));

  VAR7:=LLVBARS(LOW,50);

  VAR8:=SUM(VOL,VAR7);

  VAR9:=HHVBARS(HIGH,50);

  VAR10:=SUM(VOL,VAR9);

  VAR11:=(((CLOSE - REF(OPEN,VAR9)) / REF(OPEN,VAR9)) * 100);

  VAR12:=((VAR10 / CAPITAL) * 100);

  VAR13:=(((CLOSE - REF(OPEN,VAR7)) / REF(OPEN,VAR7)) * 100);

  VAR14:=((VAR8 / CAPITAL) * 100);

  VAR15:=(MA(WINNER(CLOSE),N) * 100);

  VAR16:=EMA(VAR4,N);

  回档不破洗盘:EMA(VAR4,N),colorFFFFFF;

  黄线下穿减仓:EMA(回档不破洗盘,N),colorFFCC66;

  无量阴跌空仓:EMA(黄线下穿减仓,N),colorCC9966;

  仅供参考:EMA(无量阴跌空仓,N),colorCC6666;

  A6:EMA(仅供参考,N),colorCC3366;

  A7:EMA(A6,N),LINETHICK2,colorCC3366;

  VAR17:=EMA(A7,N);

  VAR18:=EMA(VAR17,N);

  VAR19:=EMA(VAR18,N);

  AA:EMA(仅供参考,N2),colorFF0000;

  DRAWICON(CROSS(黄线在上持股,A7),(黄线在上持股 - 0.01),4);

  上面的这些公式源码就是牵牛波段指标的公式编写,所以如果您的股票软件中可以编写这些公式的话,那么你就可以讲这些源码直接复制进去,这样就可以调出简单实用的牵牛波段指标了,这个指标对于波段实战是非常有效的。

  牵牛波段指标公式源码的内容就为大家讲解到这里,相信大家对于这个指标有了基本的了解,如若您想要学习k线组合形态方面的投资知识可点击进入,最后希望大家投资愉快。

郑州亨瑞软件开发有限公司
版权所有

服务中心:郑州市经三路32号财富广场2号楼4楼C座
邮编:450002 网址:www.yingjia360.com

销售热线:0371-65350318/65350319
技术支持:13333833889

注册下载;